24 May 2011

No sound out of MacBook speakers & red LED in Headphone jack [Fixed]

I have recently installed Ubuntu 11.04 on my Macbook and after a few days I am now getting very low sound from the speakers as well a red LED is glowing in the Headphone jack.
The sound is perfect if I connect my headphones but if I use the speakers there is no output. I have also installed Windows and Mac OSX(Triple Boot). The speakers work fine when I use either of them as well as there being no LED.

I have re-installed the Ubuntu but then also the problem is not solved.

[FIX] : Big thanks to Vonhinten I met him on irc #ubuntu who helped me fixing this issue :)

To get the sound i added : options snd-hda-intel model=mbp55 
to the file

To turn the Red LED off - try: amixer set IEC958 off 

This fix was also featured on OMG! Ubuntu : http://www.omgubuntu.co.uk/2011/05/how-to-fix-low-sound-on-a-macbook-with-ubuntu-11-04


Hey Adwait, Can you explain how you do that to a newbie.  I have the same problem.

So, my solution was to download GNOME ALSA Mixer from the software center and "uncheck" the mute button under "speaker".  Who'd-a-thunk?

how can i fix my mac book sound red light in headset 

To Kevin & Gio_18cute : Just follow the mentioned steps, please add a comment if you find any problem.

Post a Comment

Drop in Your Comments, Problems, Suggestions, Praise, Complains or just anything.

We are always excited to hear from you.

Don't post rude or nasty comments. Ethnic slurs, personal insults and abuses are rather uncool. Criticize, but know where to draw the line.

Related Posts Plugin for WordPress, Blogger...